Unexpected Outage
Incident Report for Formitize
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 05:27 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 02, 2024 - 05:14 UTC
Monitoring
Services are coming back online and are being actively monitored by our engineering team.
Posted Sep 02, 2024 - 05:12 UTC
Update
The identified service is in the process of restoring. Thank you for your patience.
Posted Sep 02, 2024 - 04:56 UTC
Identified
Formitize is experiencing an unexpected outage. Our engineering team are working toward bringing services back online.
Posted Sep 02, 2024 - 04:32 UTC
This incident affected: API, Web Portal, Report Generator, Mobile App, Xero Integration, Core System, and Email.