Unexpected Outage
Incident Report for Formitize
Resolved
The issue is now resolved. Thank you for your patience and our sincere apology for the issue.
Posted Feb 11, 2024 - 20:18 UTC
Update
The service stability has improved greatly with the deployed fix. Our team are continuing to actively monitor. Thank you for your patience.
Posted Feb 11, 2024 - 20:03 UTC
Monitoring
The team have deployed a fix and are now monitoring.
Posted Feb 11, 2024 - 19:55 UTC
Investigating
Formitize is experiencing an unexpected outage. Our team is investigating.
Posted Feb 11, 2024 - 19:49 UTC
This incident affected: API, Web Portal, Report Generator, Mobile App, Xero Integration, Core System, and Email.