Service Interruption

Incident Report for Formitize

Resolved

This incident has been resolved.
Posted May 31, 2026 - 19:37 UTC

Monitoring

Engineers have implemented a fix and are monitoring for stability.
Posted May 31, 2026 - 19:36 UTC

Identified

The service is experiencing an unexpected outage. Engineers have identified the cause and are working toward a resolution.
Posted May 31, 2026 - 19:32 UTC
This incident affected: API, Web Portal, Report Generator, Mobile App, Xero Integration, Core System, and Email.